WordPress Automatic Upgrade Error, and the fix

If you’ve noticed today a message at your WordPress Dashboard saying new version of WordPress is available, tried the WordPress Automatic Upgrade plugin, you may have ended up with an error like this:

 

“Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /homepages/468/b1298473934/htdocs/r/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /homepages/468/b1298473934/htdocs/r/wp-content/admin/includes/class-pclzip.php on line 5498

 

There seems to be a conflict between the WordPress Automatic Upgrade plugin and the newly automatic update feature inside the core of WordPress 2.7. To overcome the problem, simply deactivate the WordPress Automatic Upgrade Plugin and try the Update again, it should fix it.

I’m not sure if the new Wodpress feature is based on the plugin or not, but apparently the Plugin will no longer be needed. Thanks a million either ways. You’ve done a lot.

 

Solution via Ryan Rampersad.

Did you enjoy this post? Why not leave a comment below and continue the conversation, or subscribe to my feed and get articles like this delivered automatically to your feed reader.

  • http://www.frankom.com Frankom

    Mabrook, and yes i removed the old plugin coz the new wordpress comes with an automated one

  • maryam

    not sure what the plug-in is for ;P

    But I got the new version note, backed up my data -after debating the issue ;P- and clicked on automatic and it went fine ;D

  • http://blogallalong.com/ Bashar

    Frankom: I think it’s the same plugin, but embedded now :). Thanks

    maryam: You didn’t know about the coolest plugin? Its what it says “Automatic Upgrade” :).

  • http://www.pricespakistan.com/ Aneeza Mubbashir

    Glad I could help!

  • Pingback: acrocera ampherotoky cancerism()